Dwelling Blocks

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
API outage
Resolved·Full outage

The API issue was resolved at 10:05 PM EDT, and task processing has returned to normal. We’re monitoring the service and investigating the root cause to prevent recurrence

Sat, Aug 15, 2026, 02:07 AM
(1 month ago)
·
Affected components
Aug 15, 2026, 02:00 AM
02:05 AM
Application
Report Submission
Updates

Resolved

The API issue was resolved at 10:05 PM EDT, and task processing has returned to normal. We’re monitoring the service and investigating the root cause to prevent recurrence

Sat, Aug 15, 2026, 02:07 AM

Investigating

Between 10:00 PM and 10:05 PM EDT, an API outage caused all tasks to fail. Service has been restored, and we’re investigating the root cause and monitoring for further issues. We apologize for the disruption

Sat, Aug 15, 2026, 02:00 AM