UCDP Maintenance in Progress: Report Submission May Be Impacted
Resolved·Partial outage

Report submission restored

Sat, Jan 24, 2026, 03:59 AM
(1 day ago)
·
Affected components
Report Submission
Updates

Resolved

Report submission restored

Sat, Jan 24, 2026, 03:59 AM

Identified

The UCDP portal is currently experiencing delays that may affect report processing. Dwelling Blocks will automatically resubmit your report once the service is restored. No action is required on your part.

Please note:

  • Your report’s upload date and time are recorded at submission, so delays will not impact the official upload date.

  • You will receive an email notification once your submission is complete.


Please refer to this article: Why Is Report Submission "In Progress" for More Than 15 Minutes?

Sat, Jan 24, 2026, 01:00 AM(2 hours earlier)